UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio and TV Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Computers

Notices

Vintage Computers Any vintage computer systems, calculators, video games etc., but with an emphasis on 1980s and earlier equipment.

Reply
 
Thread Tools
Old 3rd Nov 2020, 7:30 pm   #61
Timbucus
Octode
 
Join Date: Mar 2019
Location: Barry, Vale of Glamorgan, Wales, UK.
Posts: 1,112
Default Re: I found it !. A very sorry looking MK14

Quote:
Originally Posted by SiriusHardware View Post
Good idea to acquire one of the issue VI PCBs to use as a test bed for the ICs from your original system. Hopefully you can be a third eye on the VDU project at some point as well. There is an extra IC in the issue VI, a 74LS20 (U20) so make sure you have one of those available as well.

The IC north-west of the display with the IC 'U' number and the device number tangled up on the screen printing is either an 80L95 (as per original) or can be substituted with a 74LS365. I think Tim has tried one or two other variants in that position as well.

The two 7408s behind the display have to be 'original' 7408s and not 74(something)08. It's OK to use a 74LS08 in the U16 position, as indicated by the screen printing.
Yes I have the 80C95 version - works just as well...
Timbucus is offline   Reply With Quote
Old 3rd Nov 2020, 7:51 pm   #62
Slothie
Octode
 
Join Date: Apr 2018
Location: Newbury, Berkshire, UK.
Posts: 1,104
Default Re: I found it !. A very sorry looking MK14

Quote:
Originally Posted by SiriusHardware View Post
The IC north-west of the display with the IC 'U' number and the device number tangled up on the screen printing
Yes I must do something about that sometime... But until I need to make a significant change to the board I can't see myself getting more made so it might have to wait.
Slothie is offline   Reply With Quote
Old 3rd Nov 2020, 9:55 pm   #63
Mark1960
Heptode
 
Join Date: Mar 2020
Location: Kitchener, Ontario, Canada
Posts: 692
Default Re: I found it! A very sorry looking MK14.

Another possible way to go about troubleshooting mickie would be to connect a scrumpi style single step circuit.
Mark1960 is offline   Reply With Quote
Old 3rd Nov 2020, 10:17 pm   #64
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

I get the impression from Buz that it is the nature of all the modifications on his highly customised MK14 which are proving difficult to untangle - if the machine had been certified working when put in the loft all those years ago it would just be a case of fixing it 'as found' but I think Jeff (Buz) suspects it fell out of use because it wasn't working even then, so it's more a case of getting it working the way he originally meant it to work - 30 years or more later.
SiriusHardware is online now   Reply With Quote
Old 3rd Nov 2020, 11:55 pm   #65
Buzby123
Hexode
 
Buzby123's Avatar
 
Join Date: Oct 2011
Location: Culcheth, Cheshire, UK.
Posts: 346
Default Re: I found it! A very sorry looking MK14.

Quote:
Originally Posted by SiriusHardware View Post
... it fell out of use because it wasn't working even then, so it's more a case of getting it working the way he originally meant it to work - 30 years or more later.
Yes, it stopped working after I removed the sprite-based VDU gubbins, but by then I'd got an Apple ][e, so I didn't bother with that manky old thing, what use would that ever be again ?.

The daughter board is a real horror. I think I might give up with that, stick Micky's bits into Slothie, then start again from a known working platform.

Regarding the display-driving 7408's, what is the reason for not using LS versions ?.

Cheers,

Buzby
Buzby123 is offline   Reply With Quote
Old 4th Nov 2020, 12:25 am   #66
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

The 'plain' 7408 versions have higher output current capability or so I understand, but at the same time they also limit the current to a safe higher value so the 7-segment displays do not require current limiting resistors.

If you try to use more modern / conventional 74x08s you will probably get a rather dim display.
SiriusHardware is online now   Reply With Quote
Old 4th Nov 2020, 12:38 am   #67
Slothie
Octode
 
Join Date: Apr 2018
Location: Newbury, Berkshire, UK.
Posts: 1,104
Default Re: I found it! A very sorry looking MK14.

Quote:
Originally Posted by Buzby123 View Post
The daughter board is a real horror. I think I might give up with that, stick Micky's bits into Slothie, then start again from a known working platform.

Regarding the display-driving 7408's, what is the reason for not using LS versions ?.

Cheers,

Buzby
The resistance of the output stage is different, and I speculate that the input capacitance helps the 74ls157s latch the segment data. I don't however know of anyone whose tried LS parts so I don't know specifically that they won't work.
Slothie is offline   Reply With Quote
Old 4th Nov 2020, 1:08 am   #68
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

Quote:
Originally Posted by Mark1960 View Post
Another possible way to go about troubleshooting mickie would be...
One stunt I have used from time to time when trying to troubleshoot microprocessor based systems is to fit a much lower frequency crystal or supply a lower frequency from a generator - slows everything down and makes events much easier to see. Of course that approach only works when everything on the system is derived from one main clock.

I had an interesting experience with a microprocessor controlled functional door-entry system which I eventually tried this on. The background was that this system had been in production and working perfectly for years and then it started to become apparent that new / current examples were often declaring phones to be off-hook when they actually weren't off-hook.

The sequence was:
-User presses door panel button
-Microcontroller activates relay to connect the common circuitry to the individual phone, checks for the presence of an on-hook phone.
-If the phone is present, leave the relay energised and ring the phone.
-If the phone is absent or off-hook, de-energise the relay and display 'Off' at the door panel.

Problem was that often, a phone which was present and on-hook would fail the check, and this had only recently started happening. The energise-check-fail sequence was very fast, too fast to be able to tell what was going on so that was the point at which I dropped the crystal frequency to a quarter of the usual frequency to slow everything down.

However, far from allowing me to see what the problem was, it fixed the fault! At the same time, we also discovered that raising the system supply voltage from 12V to 14V also fixed the fault. Eventually we noticed that the relays being used in current versions of the PCB were not the same make as those in older versions, so we held a 'relay race' and discovered that the changeover speed of the new relays was considerably slower than the original parts. With the original very close timing delays in the firmware the new relays weren't being given time to get across before the phone present / absent check was carried out. Once we realised that, the delay-before-check time was increased in the firmware and that problem was finally fixed, but the breakthrough came about as a direct result of running the system at a lower speed for diagnostic purposes.
SiriusHardware is online now   Reply With Quote
Old 4th Nov 2020, 1:16 am   #69
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

Quote:
Originally Posted by Slothie
I don't however know of anyone whose tried LS parts so I don't know specifically that they won't work.
Nor do I but remember the original kit of parts contained 2 x 7408 and 1 x 74LS08, so they must have had their reasons. It would be very like Sinclair to prefer to stock only one variant so I'm surprised they didn't just supply 3 * 7408s.

Last edited by SiriusHardware; 4th Nov 2020 at 1:25 am.
SiriusHardware is online now   Reply With Quote
Old 4th Nov 2020, 12:41 pm   #70
AC/HL
Dekatron
 
AC/HL's Avatar
 
Join Date: Nov 2003
Location: Heckmondwike, West Yorkshire, UK.
Posts: 9,357
Default Re: I found it! A very sorry looking MK14.

Several references to an eBay auction edited out of this thread, it doesn't affect the ongoing discussion.
__________________
Bill, BVWS member
AC/HL is offline   Reply With Quote
Old 6th Nov 2020, 11:47 pm   #71
Buzby123
Hexode
 
Buzby123's Avatar
 
Join Date: Oct 2011
Location: Culcheth, Cheshire, UK.
Posts: 346
Default Re: I found it! A very sorry looking MK14.

Aargh !.

Transplanted all the vital organs from Micky into Slothie, but the recipient didn't spring into life, just a faint pulse detectable.

The display is being scanned, so I presume that means the 8060 is doing something and the ROMs are not totally dead. However the digits are the 'reverse C', with lots of flickering and ghosting. Keyboard does nothing.

Too late tonight to make any attempt at diagnosis.

Cheers,

Buzby
Attached Thumbnails
Click image for larger version

Name:	20201106_184851[1].jpg
Views:	76
Size:	65.1 KB
ID:	219826  
Buzby123 is offline   Reply With Quote
Old 6th Nov 2020, 11:54 pm   #72
Timbucus
Octode
 
Join Date: Mar 2019
Location: Barry, Vale of Glamorgan, Wales, UK.
Posts: 1,112
Default Re: I found it! A very sorry looking MK14.

Quote:
Originally Posted by Buzby123 View Post
Aargh !.

Transplanted all the vital organs from Micky into Slothie, but the recipient didn't spring into life, just a faint pulse detectable.

The display is being scanned, so I presume that means the 8060 is doing something and the ROMs are not totally dead. However the digits are the 'reverse C', with lots of flickering and ghosting. Keyboard does nothing.

Too late tonight to make any attempt at diagnosis.

Cheers,

Buzby
That is good progress - we will get that working over the weekend - check the soldering on the display as well as lots of reverse C could be a common with a dry joint - that happened to me...
Timbucus is offline   Reply With Quote
Old 7th Nov 2020, 12:29 am   #73
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

Reverse 'C' is, as we remember, 0x0F, or 00001111 on the databus. That's what is on the data bus when nothing else is driving it.

We have two proven examples of the issue VI working here already so we know the PCBs are OK, assuming yours was made from the exact same design files. I think I'm right in saying that the 2111 / 6xxx RAM type select link on the underside of the board should already be made in favour of 2111, but please do check that.

One possibility is that one of your bipolar PROMs may have gone faulty - they are allegedly prone to a variant of 'tin whisker disease' which happens whether the device is powered or not so it is quite possible for them to work one minute and not the next. There are various ways to check the PROMs, but in any case I think you have two sets there don't you - 'old' OS and 'new' OS - so try the other set.

Assuming you have some sort of device programmer, is it one which can also functionally test TTL ICs and maybe RAMs as well? If so, consider just running all the standard ICs through that to see if they are all OK.
SiriusHardware is online now   Reply With Quote
Old 7th Nov 2020, 1:46 am   #74
Mark1960
Heptode
 
Join Date: Mar 2020
Location: Kitchener, Ontario, Canada
Posts: 692
Default Re: I found it! A very sorry looking MK14.

Try removing as much as possible and only fit the minimum to see signs of life.

You donít need 8154 or extra ram fitted. Could probably also remove the 80L95 and maybe even one of the 74ls157 and 7408. Just look for the group of 4 and 2 digits on the display.

The 8060 is not completely dead, that usually shows a single bright digit at power on.

Its sort of scanning the display, so proms may be ok.

Might be a good idea to check the data bus for any sign of being driven high and low from different sources before swapping in any other chips. Just in case you damage both sets of proms.

Turned out to be ram chip problems on mine, possibly caused by dry joints in the address decoding. Swapping high and low ram gave different behaviour and then replacing them after waiting for delivery confirmed it was the ram.
Mark1960 is offline   Reply With Quote
Old 7th Nov 2020, 2:33 pm   #75
Slothie
Octode
 
Join Date: Apr 2018
Location: Newbury, Berkshire, UK.
Posts: 1,104
Default Re: I found it! A very sorry looking MK14.

Quote:
Originally Posted by SiriusHardware View Post
I think I'm right in saying that the 2111 / 6xxx RAM type select link on the underside of the board should already be made in favour of 2111, but please do check that.
It does, there are 2 sets of the links on the bottom, one selects RAM type and theres a tiny trace between the 2111 pads which is hard to see with black solder mask but quite visible with green.
The other link is also pre-joined and pulls SenseA to ground so the monitor works. Break if you need SenseA.
Slothie is offline   Reply With Quote
Old 7th Nov 2020, 6:49 pm   #76
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

Just to enlarge on the point about Sense-A, the 'new' monitor with the '0000 00' prompt incorporates the firmware for the single-step feature - it still needs the extra hardware shown in the manual next to the 'single step' program in the manual, and if you do not add that hardware then Sense-A has to be taken to 0V otherwise user programs will not run. Therefore, Sense-A is connected to 0V via a fine link by default on the issue VI.

This won't be the cause of your problem, just explaining why the Sense-A link is there and why it is linked by default.
SiriusHardware is online now   Reply With Quote
Old 7th Nov 2020, 10:04 pm   #77
circuitryboy
Tetrode
 
circuitryboy's Avatar
 
Join Date: Jun 2012
Location: Bristol, UK.
Posts: 55
Default Re: I found it! A very sorry looking MK14.

Your photo shows 7442 at IC13. National Semiconductor used this initially in the Keyboard Kit addon but then changed to 7445 which sinks 80mA. (Did SoC ever supply 7442?)
A fault here might give the irregular scan. (But not the x0F invalid segments)
circuitryboy is offline   Reply With Quote
Old 7th Nov 2020, 10:10 pm   #78
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

Hello circuitryboy, nice to get a pulse from you as well, given the ongoing circumstances. I don't have my original machine to hand but the parts list (original issue II) says 7445, and my issue VI (like Buzby's) also has a 7445 fitted in that position.
SiriusHardware is online now   Reply With Quote
Old 7th Nov 2020, 10:29 pm   #79
circuitryboy
Tetrode
 
circuitryboy's Avatar
 
Join Date: Jun 2012
Location: Bristol, UK.
Posts: 55
Default Re: I found it! A very sorry looking MK14.

The thumbnail doesn't enlarge well. Definitely not 7445.
If it's 7447 (!) it could explain everything.
circuitryboy is offline   Reply With Quote
Old 7th Nov 2020, 10:46 pm   #80
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 7,538
Default Re: I found it! A very sorry looking MK14.

As you know Buz populated the PCB with bits from his actual MK14 so the presence of non-canon parts there would be a bit of a mystery. The issue VI PCB has the IC type numbers screen printed on it so it would have to be a conscious decision to fit a different IC. (I've just looked at a photo I took of my issue VI PCB before I populated it, and it definitely does say 7445).
SiriusHardware is online now   Reply With Quote
Reply

Thread Tools



All times are GMT. The time now is 9:09 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2021, Paul Stenning.