View Single Post
Old 28th Nov 2021, 6:15 am   #42
Phantomrose1999
Hexode
 
Phantomrose1999's Avatar
 
Join Date: Mar 2008
Location: Melbourne, Victoria, Australia
Posts: 261
Default Re: Grundig TK27 - Low audio output

Well, the story almost ends today, as i dont have more time but this is what i found so far.

1) It did record and plays exceptionally well, see video of what was recorded on it from an Iphone 6

https://www.youtube.com/watch?v=o2g3u2okLX8

The unit is temperamental !!! observations:

The volume does drop with a lot of background hiss, and motor boating at times, especially if i press the record. The fix is the pulse the red record button enough times until it goes away.

The record bias fires up most of the time, but not 100% of the time. I did resolder half the bottom of the PCB and especially all the osc coils and related components, seems to help.

So it seems to play well, provided i dont though the record buttom.

I though it was the head playing up, and resoldered all the connections but no difference.

ONE IMPORTANT point, when the volume is low i guess its oscillating, because if i tough the input at the head and send a loud 50hz pulse, the volume comes back !! This leads me to believe the ECC81's are the problem, as i had a Grundig radio where i had the exact same symptoms, and replacing it fixed it. (motorboaring, drop in volume, etc)

So until i get some new ECC81's that it for now.

PS: the sound is just beautifuil for such a small unit. !!
Attached Thumbnails
Click image for larger version

Name:	Finished TK27 Red Reels.jpeg
Views:	33
Size:	96.3 KB
ID:	246796  
Phantomrose1999 is offline