View Single Post
Old 10th Dec 2020, 6:27 pm   #156
SiriusHardware
Dekatron
 
Join Date: Aug 2011
Location: Newcastle, Tyne and Wear, UK.
Posts: 6,754
Default Re: I found it! A very sorry looking MK14.

Buz's new-OS PROMs have arrived back and I'm just about to have a look at those - as he pointed out, the thermal label on one IC looks rather dark, and I don't remember having noticed that when I last had them. Attached, a photo I took of the PROMs working in my issue VI the first time they were here a week ago. There's no sign of heat related darkening on either PROM label at that time.

Even when working normally these devices certainly are hot-heads, when I programme pairs for other people I always place the blue and green sticky dots at one end of the devices unlike the SOC practice of putting them in the centre, right over the hot core of the IC. They don't need anything to make them run hotter than they already do.

In other news, my 4 * AM9111s arrived from the source in Germany - I've done a quick test on them all and while three work, one is unfortunately faulty. They all look absolutely brand new, legs still splayed suggesting that they had never been in a socket before I put them in my tester.

I'll get back to the supplier later to see how they handle returns. I doubt whether they have the means to test these themselves and I'm sure they were supplied in good faith.
Attached Thumbnails
Click image for larger version

Name:	Buzby_New_OS_PROMs_FirstTime.jpg
Views:	66
Size:	66.4 KB
ID:	222278  

Last edited by SiriusHardware; 10th Dec 2020 at 6:38 pm.
SiriusHardware is online now   Reply With Quote