UK Vintage Radio Repair and Restoration Discussion Forum

UK Vintage Radio Repair and Restoration Discussion Forum (https://www.vintage-radio.net/forum/index.php)
-   Vintage Amateur and Military Radio (https://www.vintage-radio.net/forum/forumdisplay.php?f=13)
-   -   Hallicrafters SX-25 Rebuild: New Mains Transformer Questions. (https://www.vintage-radio.net/forum/showthread.php?t=171995)

mrrstrat 12th Oct 2020 8:17 pm

Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
5 Attachment(s)
I was lucky enough to acquire a rather nice condition SX-25. When we got it I tested it and discovered it would power on, but NO SOUND.

What I found when I opened it up that the PT looked like it was replaced with a 700VCT PT and a 5R4 was in the place of the Type 80. So it was unsellable (and I was able to get it for next to nothing - lucky find as it is in fantastic condition).

I bought a Hammond 272FX which is a 600VCT PT with appropriate 5.0VAC and 6.3VAC.

I replaced the socket, and mounted the 272FX and proceeded to wire everything.

The AC properly goes to the primaries and produces the correct voltages to the secondaries. I grounded the secondary tap and routed them to the plates (small pins on the socket).

I wired the 5.0VAC to the type 80 socket (the fat pins) and used a red wire to serve as the rectified power. I grounded the 5.0 CT (YEL/BLA) line when during the incremental testing at each step I had 80 volts to each pin. Grounding the YEL/BLA line gave me 3.9VAC on one pin and 1.5VAC on the other.

Smoke and fire test:
- Each time I made a change I tested the chassis before and after plugin, switch on/off
- Pins had expected voltages

and then I threw on the Type 80 and repeated the test.

The type 80 flashed a bit and the plates did a most extraordinary light show for the 2-3 seconds before I switched it off.

I have never used this particular type 80 before (so I only know it tested good on my TV7), but my fear is one of the following:

- that the YEL/YEL wires did not need the CT despite the large AC voltage I observed

.OR.

- I needed to use one YEL wire and the YEL/BLA for the cathode of the type 80 (and not the dual YEL, YEL wires).

I built single and dual 5U4 rectified amplifiers for a number of years (years ago) and do not remember if I used the CT.

I included a pic of the power section I am restoring: any feedback is most appreciated (and forgive in advance any apparent dumb questions).

mrrstrat 12th Oct 2020 8:19 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
The RED/YEL and YEL/BLA are chassis grounded with bolted rings to the chassis currently.

** EDIT: and the type 80 is no more. It is as dead a a piece of wood on the TV7. I originally had it 40/40 and 47/40 on the TV7 before my test.

Station X 12th Oct 2020 8:41 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
A couple of points.

1. The centre tap of the 600V secondary winding should only be grounded when SW2 is made or there's a shorting link wired across the EX.SW terminals. Grounding it directly won't make any difference to the PSU though.

2. The yellow wires from the 5VAC secondary winding should be wired to the heater pins of the rectifier socket. The yellow/black centre tap should be insulated and left disconnected. The same goes for the green/yellow tap on the 6.3V winding.

With no rectifier plugged in you should measure 600VAC ACROSS the anode pins and 5VAC ACROSS the heater pins. In practice the voltages will be higher as there'll be no load on the transformer.

Make sure there are no shorts across the HT supply due to leaky smoothing capacitors for example.

mrrstrat 12th Oct 2020 8:50 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
You are correct on SW2: I grounded the CT purposely as I want to restore the power section first. I used a bolt to the chassis as I can easily re-route to the switch. For safety I go one change at a time and try to leave little to chance as much as possible.

I am certain I zapped the Type 80 tube - is this likely because I grounded the 5.0VAC CT? I do not remember ever using one nor did I use the 6.3VAC CT.

Station X 12th Oct 2020 8:54 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Quote:

Originally Posted by mrrstrat (Post 1298842)
I am certain I zapped the Type 80 tube - is this likely because I grounded the 5.0VAC CT? I do not remember ever using one nor did I use the 6.3VAC CT.

I don't know whether you've zapped the rectifier. You could try it off-load with the red wire to the smoothing caps disconnected.

turretslug 12th Oct 2020 9:03 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
You should most certainly not have connected the yellow/black to chassis! By doing so, you've subjected the rectifier tube and nice new transformer to a particularly brutal short test. Normally, the 5V winding centre tap is used as the point of HT (B+) DC extraction to the rest of the circuit- reservoir capacitor +ve, smoothing choke etc.

Often, the B+ is taken from one end of the rectifier heater winding as in your power supply circuit snippet - by providing a centre-tap in this case, Hammond have been kind enough to even up the distribution of the B+ current along the rectifier filament when using a directly heated rectifier like the 80 or 5R4.

Yellow to each end of the rectifier filament is correct. Fingers crossed that the transformer is still OK.

Dave757 12th Oct 2020 9:04 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Hi,

The YEL/BLA should not be grounded, - it should not be connected at all.

As this is a directly heated rectifier, the filament is at HT+ potential,
so by grounding the 5V centre tap, you are effectively grounding the HT, -
hence the light show!

It would probably be worth checking that the transformer windings are
OK before rewiring it.

Kind regards
Dave

Sorry, I got called away during my reply, and did not realise I had doubled
with the excellent advice already given
Dave

mrrstrat 12th Oct 2020 10:23 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Great advice - but I sought it after the fact :-)

The transformer is good - no ill effects and all voltages and other measurements are what I expect. The tube is toast though. All I have is some Type 83s and might venture to try one of them out after I correct the 5.0VAC CT connection..

Quote:

Originally Posted by turretslug (Post 1298850)
You should most certainly not have connected the yellow/black to chassis! By doing so, you've subjected the rectifier tube and nice new transformer to a particularly brutal short test. Normally, the 5V winding centre tap is used as the point of HT (B+) DC extraction to the rest of the circuit- reservoir capacitor +ve, smoothing choke etc.

Often, the B+ is taken from one end of the rectifier heater winding as in your power supply circuit snippet - by providing a centre-tap in this case, Hammond have been kind enough to even up the distribution of the B+ current along the rectifier filament when using a directly heated rectifier like the 80 or 5R4.

Yellow to each end of the rectifier filament is correct. Fingers crossed that the transformer is still OK.


mrrstrat 12th Oct 2020 10:29 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Currently - and until I verify all is well - the red wire was never connected to anything and only available for me to observe rectified DC. It is totally off load - I do see signs of burned caps and a resistor that looks medium-well that the previous owner looked to do with his retrofit of a 700VCT power supply to replace the one that burned up.

As I said, I tested the connection of A/C wires to set to make sure proper grounding and chassis state was good, then proceeded to connect the PT and test on/off with seeing power on the secondaries. I got to rectifier test and had to stop as I am out of type 80s.

I am assuming one of my type 83s will serve as a testable rectifier - next test I am doing..


** EDIT: I tried the type 83 in the place of another 80. I got 315VDC to each cathode pin.


Quote:

Originally Posted by Station X (Post 1298845)
Quote:

Originally Posted by mrrstrat (Post 1298842)
I am certain I zapped the Type 80 tube - is this likely because I grounded the 5.0VAC CT? I do not remember ever using one nor did I use the 6.3VAC CT.

I don't know whether you've zapped the rectifier. You could try it off-load with the red wire to the smoothing caps disconnected.


turretslug 12th Oct 2020 10:43 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
I think it would be best to get hold of a known good 80 before going much further- the 83 is a mercury vapour type which are best used with choke-input supply arrangements as their low impedance means that they can be damaged by the high peak currents possible with capacitor-input filters.

mrrstrat 13th Oct 2020 12:04 am

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Yes - I plan to get a couple of them. I do have the power supply unconnected as the previous owner looked like he was also wiring out the A/C plug. The whole power section needs work.

Both the 80 and 83 are somewhat expensive in the US so I am trying to be careful :-)

Quote:

Originally Posted by turretslug (Post 1298891)
I think it would be best to get hold of a known good 80 before going much further- the 83 is a mercury vapour type which are best used with choke-input supply arrangements as their low impedance means that they can be damaged by the high peak currents possible with capacitor-input filters.


mrrstrat 13th Oct 2020 3:18 am

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
I stand corrected: the type 80 is not so bad, but the 83s are not inexpensive.

I was able to get a good type 80 and my power section is fine now (transformer is good and not stressed).

turretslug 13th Oct 2020 11:46 am

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
That's good news- I had a look over at Antique Radio Forums (always good to get a US perspective on these things) and I see that there seems to be a scam where Russian hard vacuum valves/tubes similar to 5U4G are being re-based and re-marked as 83s! They must be getting quite pricey for that sort of chicanery.

mrrstrat 13th Oct 2020 11:58 am

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
I like the Antique Radio forum too - to me this forum and the Antique Radio forum are proof there are radio nerds world-wide :-).
My friend who has over 300 radios in his collection jumped on me about risking one of my Type 83s yesterday as they are expensive. I have seen them as cheap as $20.00 USD but all of the ones I have were north of $40-$50 USD.

And I have been trying to break the American habit of calling valves "tubes" for many years now. Calling them tubes seems to take away from them the fact they ARE valves electronically speaking most of the time.

mrrstrat 14th Oct 2020 12:12 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
1 Attachment(s)
Update on radio: I repaired the poor work and bad modifications. One curious "mod" made by the previous owner was the soldering large wire wound resistor off of the A/C plug to bleed off the excessive voltage from the 700VCT transformer he had installed on it. And it looked to be a 10-15 watt Ohmite of a value I could not read as it was obviously smoked at some point.

Then I did the smoke and fire test and the radio came right up!

The alignment is near perfect (amazingly) and the crystal is sharp and functional at all of the settings. BFO is strong and works as expected.

I am getting about 285VDC off of the rectifier (for the B+) - I would have thought this would have been higher but the set seems to be doing great - I played it for a couple hours yesterday and will be using it to power music in the office today (I do an extended smoke and fire test and extended endurance test for my own radios).

I am amazed at the rich sound this set has. The P/P audio is definitely a difference. I SX-43 has great sound but the SX-25 is in a different league altogether.

I enclosed the replacement cap the previous owner put in - I have been told it is a "universal" replacement can. I never heard of these and always used the correct replacement. Anyway it is a 20uF to 40Uf replacement can and exceeds the 30-10-10-10-10 I need, but since its a filter I expected no ill effects. But my experience with amplifiers told me the overall bass response of the audio would be affected. I do see that effect as it has crisp highs and thundering lows and can be overloaded when too loud - I will replace the can at some point but I am still proofing the circuit.

Thanks all for the help in getting this going and it looks like I dodged a major bullet with the grounded CT on the 5.0VDC line. The set appears to have had no ill effects whatsoever. The time it was on and burned up the last type 80 was literally 2-3 seconds at the most. I have burned power valves up in seconds in the past so I was ready to switch it off during this test - I would have thought the 80 valve was more robust than that, but apparently they are not invincible.

usradcoll1 14th Oct 2020 4:30 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Quote:

Originally Posted by mrrstrat (Post 1299388)
Update on radio: I repaired the poor work and bad modifications. One curious "mod" made by the previous owner was the soldering large wire wound resistor off of the A/C plug to bleed off the excessive voltage from the 700VCT transformer he had installed on it. And it looked to be a 10-15 watt Ohmite of a value I could not read as it was obviously smoked at some point.

Then I did the smoke and fire test and the radio came right up!

The alignment is near perfect (amazingly) and the crystal is sharp and functional at all of the settings. BFO is strong and works as expected.

I am getting about 285VDC off of the rectifier (for the B+) - I would have thought this would have been higher but the set seems to be doing great - I played it for a couple hours yesterday and will be using it to power music in the office today (I do an extended smoke and fire test and extended endurance test for my own radios).

I am amazed at the rich sound this set has. The P/P audio is definitely a difference. I SX-43 has great sound but the SX-25 is in a different league altogether.

I enclosed the replacement cap the previous owner put in - I have been told it is a "universal" replacement can. I never heard of these and always used the correct replacement. Anyway it is a 20uF to 40Uf replacement can and exceeds the 30-10-10-10-10 I need, but since its a filter I expected no ill effects. But my experience with amplifiers told me the overall bass response of the audio would be affected. I do see that effect as it has crisp highs and thundering lows and can be overloaded when too loud - I will replace the can at some point but I am still proofing the circuit.

Thanks all for the help in getting this going and it looks like I dodged a major bullet with the grounded CT on the 5.0VDC line. The set appears to have had no ill effects whatsoever. The time it was on and burned up the last type 80 was literally 2-3 seconds at the most. I have burned power valves up in seconds in the past so I was ready to switch it off during this test - I would have thought the 80 valve was more robust than that, but apparently they are not invincible.

Do you have different service information on the SX25. The Riders pages I have don't show the voltages expected on the various valves or the H/T or B+.
Dave, USradcoll1 About 150 miles from the O/P in Wisconsin.

mrrstrat 14th Oct 2020 6:26 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
The best info I was ever able to find was that the Type 80 cathode voltage ranges from 200-350 volts. I am at 285VDC or about 80% of what the max is supposed to be.

I cannot verify that the "nominal" voltage is 275VDC, nor the working range is +/-75VDC as I have found no concrete documentation of what nominals should be. Perhaps there is a Sams Photofact out there yet to be discovered for the SX-25.

I can say that my set is operating with 285VDC at the Type 80 cathode under load and is working great.

ms660 14th Oct 2020 6:56 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
1 Attachment(s)
Any use?

mrrstrat 14th Oct 2020 7:02 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Yes!!!!

usradcoll1 16th Oct 2020 2:44 pm

Re: Hallicrafters SX-25 Rebuild: New Mains Transformer Questions.
 
Quote:

Originally Posted by ms660 (Post 1299549)
Any use?

Great information!
IDK why Hallicrafters didn't include voltage and resistance values on the pre-war models. When working on a somewhat working example, experience working on a similar model would give an idea of what the proper voltage to be expected on the various circuits.
USradcoll1, with a lot of experience on Hallicrafters sets.
Dave, :wave:


All times are GMT. The time now is 5:55 pm.

Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2020, Paul Stenning.